// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:listget|name|number)\(([^\)]+)\)").unwrap();
let string = "name(abc1)
number(param9)
listget(12jtxgh)
(name(foo) & number(bar)) - listget(baz)
def number(param9)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}