$re = '/(?<=&|^)(?i)key(?-i)=[^&\n]*/m';
$str = 'cool=13&nice=zz&key=value&polo=0
Key=value&cool=13&nice=zz&polo=0
cool=13&nice=zz&polo=0&key=value
cool=13&nice=zz&myKey=value&polo=0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);