package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[a-z] [a-z](*SKIP)(*FAIL)| `)
var str = `英文 中文 English something else`
var substitution = "_"
fmt.Println(re.ReplaceAllString(str, substitution))
}