$re = '/The puctuation character in the ASCII table are: !"#\$%&\'\(\)\*\+,-\.\/:;<=>\?@\[\\\\]\^_`\{\|}~/m';
$str = 'The puctuation character in the ASCII table are: !"#$%&\'()*+,-./:;<=>?@[\\]^_`{|}~
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);