package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<negative>\-?)(?<preceding>0?)(?<main>[0-9]+\.??[0-9]*?)(?<trailing>\.?0*)$`)
var str = `00.00
00.010
0.
11.010
11
123.123
-239.010
010.0010
-001.10`
var substitution = "$1$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}