const regex = /^(?<negative>\-?)(?<preceding>0?)(?<main>[0-9]+\.??[0-9]*?)(?<trailing>\.?0*)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<negative>\\-?)(?<preceding>0?)(?<main>[0-9]+\\.??[0-9]*?)(?<trailing>\\.?0*)$', 'mg')
const str = `00.00
00.010
0.
11.010
11
123.123
-239.010
010.0010
-001.10`;
const subst = `$1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);