// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\bopt[123]\b\s*(.*?)\s*because_of_this\b").unwrap();
let string = "other text opt1 opt2 opt3 I_want_only_this_text because_of_this";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}