using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=opt1|opt2|opt3)(?:(?!opt1|opt2|opt3).)*?(?=because_of_this)";
string input = @"other text opt1 opt2 opt3 I_want_only_this_text because_of_this";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}