$re = '/(\w)(.+?)(@)(\w)(.+?)(.\w+$)/m';
$str = 'jaojao-pe-de-feijao.brasileiro@fortalnet.com.br
aristides.souza-ce@sistemas.auditivo.gov.eu.sis.at';
$subst = "$1*****$3$4*****$6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;