using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".* - (.*) - .*.(mp4)";
string substitution = @"$1.$2";
string input = @"8teenBoy (Helix Studios) - Testing the Tutor - Trevor Harris & Julian Bell [720p].mp4";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}