package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.* - (.*) - .*.(mp4)`)
var str = `8teenBoy (Helix Studios) - Testing the Tutor - Trevor Harris & Julian Bell [720p].mp4`
var substitution = "$1.$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}