$re = '/.* - (.*) - .*.(mp4)/';
$str = '8teenBoy (Helix Studios) - Testing the Tutor - Trevor Harris & Julian Bell [720p].mp4';
$subst = "$1.$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;