re = /.* - (.*) - .*.(mp4)/
str = '8teenBoy (Helix Studios) - Testing the Tutor - Trevor Harris & Julian Bell [720p].mp4'
subst = '$1.$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result