using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:sandwich|toastie)(?:(?!\w\. ).){0,100}(ham|cheese|pickle)";
string input = @"Andy sat down to enjoy his sandwich which, unusally for him, was filled with delicious ham
Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}