import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:sandwich|toastie)(?:(?!\\w\\. ).){0,100}(ham|cheese|pickle)";
final String string = "Andy sat down to enjoy his sandwich which, unusally for him, was filled with delicious ham\n"
+ "Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}