const regex = /(?:sandwich|toastie)(?:(?!\w\. ).){0,100}(ham|cheese|pickle)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:sandwich|toastie)(?:(?!\\w\\. ).){0,100}(ham|cheese|pickle)', 'gm')
const str = `Andy sat down to enjoy his sandwich which, unusally for him, was filled with delicious ham
Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}