re = /(?:sandwich|toastie)(?:(?!\w\. ).){0,100}(ham|cheese|pickle)/m
str = 'Andy sat down to enjoy his sandwich which, unusally for him, was filled with delicious ham
Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end