using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!){0}([A-Z]{2} [0-9]{7})$";
string input = @"AB 1234567
AAA 1234567
AB 12345678
A1 1234567
AB A123456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}