$re = '/^(?!){0}([A-Z]{2} [0-9]{7})$/m';
$str = 'AB 1234567
AAA 1234567
AB 12345678
A1 1234567
AB A123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);