#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)@(\w+)"
Local $sString = "[quote]" & @CRLF & _
"" & @CRLF & _
"@lalalala" & @CRLF & _
"" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur adipiscing elit. Cras viverra ornare lectus sit amet dignissim. Vestibulum a mi leo. Nunc placerat accumsan elit, nec luctus ante malesuada sed. Quisque at urna non erat suscipit pharetra." & @CRLF & _
"" & @CRLF & _
"[/quote]" & @CRLF & _
"" & @CRLF & _
"Morbi massa mauris, consequat vitae sem eu, maximus posuere ligula. Fusce pretium ultricies lectus sit amet bibendum. Aliquam nec dolor urna."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")