const regex = /@(\w+)/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@(\\w+)', 'gis')
const str = `[quote]
@lalalala
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Cras viverra ornare lectus sit amet dignissim. Vestibulum a mi leo. Nunc placerat accumsan elit, nec luctus ante malesuada sed. Quisque at urna non erat suscipit pharetra.
[/quote]
Morbi massa mauris, consequat vitae sem eu, maximus posuere ligula. Fusce pretium ultricies lectus sit amet bibendum. Aliquam nec dolor urna.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}