$re = '/(?i)\n?-* ?(?:BEGIN|END) (?:(?:PRIVATE|PUBLIC)(?: RSA)?|RSA (?:PRIVATE|PUBLIC)) KEY ?-*\n?/m';
$str = '-----BEGIN RSA PUBLIC KEY-----
0123456789
0123456789
abcdefgh
-----END RSA PUBLIC KEY-----';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);