// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\S+)\t(\S+)\t(\S+)$").unwrap();
let string = "AAAA BBBBBBBBBBBBBBB CCCC";
let substitution = "$1_$3 $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}