#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?ix)(?>[^\S ]\s*|\s{2,})(?=(?:(?:[^<]++|<(?!\/?(?:textarea|pre)\b))*+)(?:<(?>textarea|pre)\b|\z))"
Local $sString = "<body>" & @CRLF & _
" <section id="fd-container" class="bgFFF celupSection">" & @CRLF & _
" <div class="container">" & @CRLF & _
" <div class="row">" & @CRLF & _
" <div id="primary" class="col-md-9 content-area">" & @CRLF & _
" <main id="main" role="main">" & @CRLF & _
" <div class="table-info"><span class="info">테이블번호: 13</span></div>" & @CRLF & _
" <article id="post-445" class="post-content post-445 company type-company status-publish has-post-thumbnail hentry category-32 wpautop">" & @CRLF & _
" <header class="entry-header"><span class="screen-reader-text">할머니잔치국수</span>" & @CRLF & _
" <h1 class="entry-title">할머니잔치국수</h1>" & @CRLF & _
" </header>" & @CRLF & _
" <div class="entry-content">" & @CRLF & _
" <div class="vc_row wpb_row vc_row-fluid">" & @CRLF & _
" <div class="wpb_column vc_column_container vc_col-sm-12">" & @CRLF & _
" <div class="vc_column-inner">" & @CRLF & _
" <div class="wpb_wrapper">" & @CRLF & _
" <div class="wpb_text_column wpb_content_element">" & @CRLF & _
" <div class="wpb_wrapper">" & @CRLF & _
" <div class="fd-foodDetailProBox style1">" & @CRLF & _
" <ul class="fd-foodDetailProList">" & @CRLF & _
" <li class="fd-foodDetailPro fd-flex">" & @CRLF & _
" <div class="fd-foodDetailProLeft fd-flex">" & @CRLF & _
" <div class="fd-foodProLeftTitleBox">" & @CRLF & _
" <div class="fd-foodProImg"><img width="66" height="66" src="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-100x100.jpg" alt="" srcset="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-60x60.jpg 60w" sizes="(max-width: 66px) 100vw, 66px" class="attachment-66x66 size-66x66" /></div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodProLeftContentBox">" & @CRLF & _
" <div class="fd-foodProSubTitle">비빔국수</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">최상의 마법 비빔국수</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">영양정보 칼로리 313kcal</div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodDetailProRight fd-flex fd-align-center fd-justy-center">" & @CRLF & _
" <div class="fd-foodDetailProPrice">4,900</div>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="fd-foodDetailPro fd-flex">" & @CRLF & _
" <div class="fd-foodDetailProLeft fd-flex">" & @CRLF & _
" <div class="fd-foodProLeftTitleBox">" & @CRLF & _
" <div class="fd-foodProImg"><img width="66" height="66" src="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-100x100.jpg" alt="" srcset="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-60x60.jpg 60w" sizes="(max-width: 66px) 100vw, 66px" class="attachment-66x66 size-66x66" /></div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodProLeftContentBox">" & @CRLF & _
" <div class="fd-foodProSubTitle">잔치국수</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">할머니의 정성이 잔득 담긴 잔치국수</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">영양정보 칼로리 280kcal</div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodDetailProRight fd-flex fd-align-center fd-justy-center">" & @CRLF & _
" <div class="fd-foodDetailProPrice">4,900</div>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="fd-foodDetailPro fd-flex">" & @CRLF & _
" <div class="fd-foodDetailProLeft fd-flex">" & @CRLF & _
" <div class="fd-foodProLeftTitleBox">" & @CRLF & _
" <div class="fd-foodProImg"><img width="66" height="66" src="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-100x100.jpg" alt="" srcset="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-60x60.jpg 60w" sizes="(max-width: 66px) 100vw, 66px" class="attachment-66x66 size-66x66" /></div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodProLeftContentBox">" & @CRLF & _
" <div class="fd-foodProSubTitle">콩국수</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">직접 빚어 만든 콩국수</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">영양정보 칼로리 354kcal</div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodDetailProRight fd-flex fd-align-center fd-justy-center">" & @CRLF & _
" <div class="fd-foodDetailProPrice">5,900</div>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="fd-foodDetailPro fd-flex">" & @CRLF & _
" <div class="fd-foodDetailProLeft fd-flex">" & @CRLF & _
" <div class="fd-foodProLeftTitleBox">" & @CRLF & _
" <div class="fd-foodProImg"><img width="66" height="66" src="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-100x100.jpg" alt="" srcset="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-60x60.jpg 60w" sizes="(max-width: 66px) 100vw, 66px" class="attachment-66x66 size-66x66" /></div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodProLeftContentBox">" & @CRLF & _
" <div class="fd-foodProSubTitle">도토리묵</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">깻잎과 도토리묵 환상 컴비네이션</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">영양정보 칼로리 423kcal</div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodDetailProRight fd-flex fd-align-center fd-justy-center">" & @CRLF & _
" <div class="fd-foodDetailProPrice">8,900</div>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="fd-foodDetailPro fd-flex">" & @CRLF & _
" <div class="fd-foodDetailProLeft fd-flex">" & @CRLF & _
" <div class="fd-foodProLeftTitleBox">" & @CRLF & _
" <div class="fd-foodProImg"><img width="66" height="66" src="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-100x100.jpg" alt="" srcset="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-60x60.jpg 60w" sizes="(max-width: 66px) 100vw, 66px" class="attachment-66x66 size-66x66" /></div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodProLeftContentBox">" & @CRLF & _
" <div class="fd-foodProSubTitle">물만두</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">한입에 속 식감이 살아 있는 물만두</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">영양정보 칼로리 154kcal</div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodDetailProRight fd-flex fd-align-center fd-justy-center">" & @CRLF & _
" <div class="fd-foodDetailProPrice">6,900</div>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" <li class="fd-foodDetailPro fd-flex">" & @CRLF & _
" <div class="fd-foodDetailProLeft fd-flex">" & @CRLF & _
" <div class="fd-foodProLeftTitleBox">" & @CRLF & _
" <div class="fd-foodProImg"><img width="66" height="66" src="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-100x100.jpg" alt="" srcset="http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-60x60.jpg 60w" sizes="(max-width: 66px) 100vw, 66px" class="attachment-66x66 size-66x66" /></div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodProLeftContentBox">" & @CRLF & _
" <div class="fd-foodProSubTitle">파전</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">군침이 감도는 해물파전</div>" & @CRLF & _
" <div class="fd-foodProLeftContent">영양정보 칼로리 654kcal</div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="fd-foodDetailProRight fd-flex fd-align-center fd-justy-center">" & @CRLF & _
" <div class="fd-foodDetailProPrice">13,900</div>" & @CRLF & _
" </div>" & @CRLF & _
" </li>" & @CRLF & _
" </ul>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </article>" & @CRLF & _
" </main>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </section>" & @CRLF & _
"</body>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")