# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?ix)(?>[^\S ]\s*|\s{2,})(?=(?:(?:[^<]++|<(?!\/?(?:textarea|pre)\b))*+)(?:<(?>textarea|pre)\b|\z))"
test_str = ("<body>\n"
" <section id=\"fd-container\" class=\"bgFFF celupSection\">\n"
" <div class=\"container\">\n"
" <div class=\"row\">\n"
" <div id=\"primary\" class=\"col-md-9 content-area\">\n"
" <main id=\"main\" role=\"main\">\n"
" <div class=\"table-info\"><span class=\"info\">테이블번호: 13</span></div>\n"
" <article id=\"post-445\" class=\"post-content post-445 company type-company status-publish has-post-thumbnail hentry category-32 wpautop\">\n"
" <header class=\"entry-header\"><span class=\"screen-reader-text\">할머니잔치국수</span>\n"
" <h1 class=\"entry-title\">할머니잔치국수</h1>\n"
" </header>\n"
" <div class=\"entry-content\">\n"
" <div class=\"vc_row wpb_row vc_row-fluid\">\n"
" <div class=\"wpb_column vc_column_container vc_col-sm-12\">\n"
" <div class=\"vc_column-inner\">\n"
" <div class=\"wpb_wrapper\">\n"
" <div class=\"wpb_text_column wpb_content_element\">\n"
" <div class=\"wpb_wrapper\">\n"
" <div class=\"fd-foodDetailProBox style1\">\n"
" <ul class=\"fd-foodDetailProList\">\n"
" <li class=\"fd-foodDetailPro fd-flex\">\n"
" <div class=\"fd-foodDetailProLeft fd-flex\">\n"
" <div class=\"fd-foodProLeftTitleBox\">\n"
" <div class=\"fd-foodProImg\"><img width=\"66\" height=\"66\" src=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-100x100.jpg\" alt=\"\" srcset=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-60x60.jpg 60w\" sizes=\"(max-width: 66px) 100vw, 66px\" class=\"attachment-66x66 size-66x66\" /></div>\n"
" </div>\n"
" <div class=\"fd-foodProLeftContentBox\">\n"
" <div class=\"fd-foodProSubTitle\">비빔국수</div>\n"
" <div class=\"fd-foodProLeftContent\">최상의 마법 비빔국수</div>\n"
" <div class=\"fd-foodProLeftContent\">영양정보 칼로리 313kcal</div>\n"
" </div>\n"
" </div>\n"
" <div class=\"fd-foodDetailProRight fd-flex fd-align-center fd-justy-center\">\n"
" <div class=\"fd-foodDetailProPrice\">4,900</div>\n"
" </div>\n"
" </li>\n"
" <li class=\"fd-foodDetailPro fd-flex\">\n"
" <div class=\"fd-foodDetailProLeft fd-flex\">\n"
" <div class=\"fd-foodProLeftTitleBox\">\n"
" <div class=\"fd-foodProImg\"><img width=\"66\" height=\"66\" src=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-100x100.jpg\" alt=\"\" srcset=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-60x60.jpg 60w\" sizes=\"(max-width: 66px) 100vw, 66px\" class=\"attachment-66x66 size-66x66\" /></div>\n"
" </div>\n"
" <div class=\"fd-foodProLeftContentBox\">\n"
" <div class=\"fd-foodProSubTitle\">잔치국수</div>\n"
" <div class=\"fd-foodProLeftContent\">할머니의 정성이 잔득 담긴 잔치국수</div>\n"
" <div class=\"fd-foodProLeftContent\">영양정보 칼로리 280kcal</div>\n"
" </div>\n"
" </div>\n"
" <div class=\"fd-foodDetailProRight fd-flex fd-align-center fd-justy-center\">\n"
" <div class=\"fd-foodDetailProPrice\">4,900</div>\n"
" </div>\n"
" </li>\n"
" <li class=\"fd-foodDetailPro fd-flex\">\n"
" <div class=\"fd-foodDetailProLeft fd-flex\">\n"
" <div class=\"fd-foodProLeftTitleBox\">\n"
" <div class=\"fd-foodProImg\"><img width=\"66\" height=\"66\" src=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-100x100.jpg\" alt=\"\" srcset=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-60x60.jpg 60w\" sizes=\"(max-width: 66px) 100vw, 66px\" class=\"attachment-66x66 size-66x66\" /></div>\n"
" </div>\n"
" <div class=\"fd-foodProLeftContentBox\">\n"
" <div class=\"fd-foodProSubTitle\">콩국수</div>\n"
" <div class=\"fd-foodProLeftContent\">직접 빚어 만든 콩국수</div>\n"
" <div class=\"fd-foodProLeftContent\">영양정보 칼로리 354kcal</div>\n"
" </div>\n"
" </div>\n"
" <div class=\"fd-foodDetailProRight fd-flex fd-align-center fd-justy-center\">\n"
" <div class=\"fd-foodDetailProPrice\">5,900</div>\n"
" </div>\n"
" </li>\n"
" <li class=\"fd-foodDetailPro fd-flex\">\n"
" <div class=\"fd-foodDetailProLeft fd-flex\">\n"
" <div class=\"fd-foodProLeftTitleBox\">\n"
" <div class=\"fd-foodProImg\"><img width=\"66\" height=\"66\" src=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-100x100.jpg\" alt=\"\" srcset=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-60x60.jpg 60w\" sizes=\"(max-width: 66px) 100vw, 66px\" class=\"attachment-66x66 size-66x66\" /></div>\n"
" </div>\n"
" <div class=\"fd-foodProLeftContentBox\">\n"
" <div class=\"fd-foodProSubTitle\">도토리묵</div>\n"
" <div class=\"fd-foodProLeftContent\">깻잎과 도토리묵 환상 컴비네이션</div>\n"
" <div class=\"fd-foodProLeftContent\">영양정보 칼로리 423kcal</div>\n"
" </div>\n"
" </div>\n"
" <div class=\"fd-foodDetailProRight fd-flex fd-align-center fd-justy-center\">\n"
" <div class=\"fd-foodDetailProPrice\">8,900</div>\n"
" </div>\n"
" </li>\n"
" <li class=\"fd-foodDetailPro fd-flex\">\n"
" <div class=\"fd-foodDetailProLeft fd-flex\">\n"
" <div class=\"fd-foodProLeftTitleBox\">\n"
" <div class=\"fd-foodProImg\"><img width=\"66\" height=\"66\" src=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-100x100.jpg\" alt=\"\" srcset=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-60x60.jpg 60w\" sizes=\"(max-width: 66px) 100vw, 66px\" class=\"attachment-66x66 size-66x66\" /></div>\n"
" </div>\n"
" <div class=\"fd-foodProLeftContentBox\">\n"
" <div class=\"fd-foodProSubTitle\">물만두</div>\n"
" <div class=\"fd-foodProLeftContent\">한입에 속 식감이 살아 있는 물만두</div>\n"
" <div class=\"fd-foodProLeftContent\">영양정보 칼로리 154kcal</div>\n"
" </div>\n"
" </div>\n"
" <div class=\"fd-foodDetailProRight fd-flex fd-align-center fd-justy-center\">\n"
" <div class=\"fd-foodDetailProPrice\">6,900</div>\n"
" </div>\n"
" </li>\n"
" <li class=\"fd-foodDetailPro fd-flex\">\n"
" <div class=\"fd-foodDetailProLeft fd-flex\">\n"
" <div class=\"fd-foodProLeftTitleBox\">\n"
" <div class=\"fd-foodProImg\"><img width=\"66\" height=\"66\" src=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-100x100.jpg\" alt=\"\" srcset=\"http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-60x60.jpg 60w\" sizes=\"(max-width: 66px) 100vw, 66px\" class=\"attachment-66x66 size-66x66\" /></div>\n"
" </div>\n"
" <div class=\"fd-foodProLeftContentBox\">\n"
" <div class=\"fd-foodProSubTitle\">파전</div>\n"
" <div class=\"fd-foodProLeftContent\">군침이 감도는 해물파전</div>\n"
" <div class=\"fd-foodProLeftContent\">영양정보 칼로리 654kcal</div>\n"
" </div>\n"
" </div>\n"
" <div class=\"fd-foodDetailProRight fd-flex fd-align-center fd-justy-center\">\n"
" <div class=\"fd-foodDetailProPrice\">13,900</div>\n"
" </div>\n"
" </li>\n"
" </ul>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </article>\n"
" </main>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </section>\n"
"</body>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.