const regex = /loc=((?:(?!\s,).)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('loc=((?:(?!\\s,).)*)', 'gm')
const str = `loc=/abc/flows/timespan/2021-08-10T11:35:00+00:00_2021-08-10T12:35:00+00:00/ip_initiate/10.101.10.20/data.ext
loc=\\"{\\"type\\":1,\\"namespace\\":\\"flows\\",\\"appIds\\":\\"10,11,12\\",\\"path_bar\\":\\"[\\\\\\"ip_initiate=10.1.120.11\\\\\\"]\\",\\"2021-08-10T11:35:00+00:00_2021-08-10T12:35:00+00:00\\\\/ip_initiate\\\\/10.1.120.11\\\\/http_code\\\\/200\\",\\"restrict\\":null}\\"", day=xyz
loc=\\"{\\"type\\":1,\\"namespace\\":\\"flows\\",\\"appIds\\":\\"10,11,12\\",\\"path_bar\\":\\"[\\\\\\"ip_initiate=10.1.120.11\\\\\\"]\\",\\"2021-08-10T11:35:00+00:00_2021-08-10T12:35:00+00:00\\\\/ip_initiate\\\\/10.1.120.11\\\\/http_code\\\\/200\\",\\"restrict\\":null}\\"", ip=10.10.10.10
loc=\\"/timespan/2021-09-12T14:21:00/ip_responder/10.10.10.10/,country=xyz,dns=example.com,http:code=2548:111:0:0:0:0:182.25.236.2:10\\"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}