using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test)(\([\w-]*\))?(!:|:.*\n\n((.+\n)+\n)?BREAKING CHANGE:)|💥)";
string input = @"feat!: message
feat(scope)!: message
feat(scope-scope)!: message
💥message
feat(scope scope)!: message
feat: ABC-123 message
feat: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message
feat(scope): message";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}