package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test)(\([\w-]*\))?(!:|:.*\n\n((.+\n)+\n)?BREAKING CHANGE:)|💥)`)
var str = `feat!: message
feat(scope)!: message
feat(scope-scope)!: message
💥message
feat(scope scope)!: message
feat: ABC-123 message
feat: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message
feat(scope): message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}