const regex = /^((build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test)(\([\w-]*\))?(!:|:.*\n\n((.+\n)+\n)?BREAKING CHANGE:)|💥)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test)(\\([\\w-]*\\))?(!:|:.*\\n\\n((.+\\n)+\\n)?BREAKING CHANGE:)|💥)', 'gm')
const str = `feat!: message
feat(scope)!: message
feat(scope-scope)!: message
💥message
feat(scope scope)!: message
feat: ABC-123 message
feat: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message
feat(scope): message`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}