import Foundation
let pattern = #"^((build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test)(\([\w-]*\))?(!:|:.*\n\n((.+\n)+\n)?BREAKING CHANGE:)|💥)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
feat!: message
feat(scope)!: message
feat(scope-scope)!: message
💥message
feat(scope scope)!: message
feat: ABC-123 message
feat: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message
feat(scope): message
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)