#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<start_date>\d{4}).*?)?(?<end_date>\d{4}|(?<=-)\d{2})?$"
Local $sString = "May 30, 1949, published 1979" & @CRLF & _
"May 30, 1949 and 1951, published 1979" & @CRLF & _
"May 30, 1949, printed 1980" & @CRLF & _
"May 30, 1949, print executed 1988" & @CRLF & _
"May 30, 1949, prints executed 1988" & @CRLF & _
"published 1940" & @CRLF & _
"August or September 1908" & @CRLF & _
"May 30, 1949" & @CRLF & _
"May 30, 1949, printed" & @CRLF & _
"1920" & @CRLF & _
"1920-21"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")