package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:wo)?man`)
var str = `Woman
Man
woman
man
wOmAn
MaN`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}