import re
regex = re.compile(r"^(\s+)?(((([a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)|([a-zA-Z ]+))(\s+)?$", flags=re.MULTILINE)
test_str = (" ‘Dabes Zarger Gackett\n"
" Manes Hackett` Barger\n"
" Modil Gobam ‘Nomes\n"
" Jarrett Bar,ger Hackett, \n"
" LuIs T’rivino\n"
" LuIs Triv,ino \n"
" Roofer ‘doores \n"
" Steven JR Morr's\n"
" Pakkir Ab’dul Kalam\n"
" Ku,mar\n"
" Pakkir A–bdul Kalam\n"
" Pakkir Ab–dul Kalam\n"
" Ar-t-hur\n"
" M \n"
" m\n"
" sp\n"
" Mayank S-hankar\n"
" mayank \n"
" shankar\n"
" jainuddin ad\n"
" jainuddin a\n"
" abd-ul\n"
" Pakkir A'bdul Kalam\n"
" Pakkir Ab’dul Kalam\n"
" Pakkir Ab'dul Kalam\n"
" Pakkir Ab`dul Kalam\n"
" Kumar A\n"
" A kumar\n"
" Ku,mar\n"
" Pakkir A-bdul Kalam\n"
" Pakkir Ab-dul Kalam\n"
" Pakkir A–bdul Kalam\n"
" Pakkir Ab–dul Kalam\n"
" Pakkir Abdul Kalam")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")