use strict;
my $str = '{
label: "Other",
value: "Other",
},';
my $regex = qr/^{\R\h{2,}label:\h+"Other",\R\h{2,}value:\h+"Other",\R},/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";