import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-f\\d]{1,4}:){7}[a-f\\d]{1,4}$";
final String string = "1050:1000:1000:a000:5:600:300c:326b\n"
+ "1050:1000:2000:ab00:5:600:300c:326a\n"
+ "1050:1000:3000:abc0:5:600:300c:326c\n"
+ "1051:1000:4000:abcd:5:600:300c:326b\n"
+ "1050:0:0:0:5:600:300c:326b\n"
+ "1050:0:0:0:5:600:300c:326a\n"
+ "1050:0:0:0:5:600:300c:326c\n"
+ "1051:0:0:0:5:600:300c:326b\n"
+ "1050:10:0:0:5:600:300c:326b\n"
+ "1050:10:0:0:5:600:300c:326a\n"
+ "1050:10:0:0:5:600:300c:326c\n"
+ "1051:10:0:0:5:600:300c:326b\n"
+ "1050:10:0:0:15:600:300c:326b\n"
+ "1050:10:0:10:5:600:300c:326a\n"
+ "1050:10:10:0:5:600:300c:326c\n"
+ "1051:110:0:0:5:600:300c:326b\n\n"
+ "1050:10:0:0:15:600:300c:326k\n"
+ "1050:10:0:0:15:600:300c:326g\n"
+ "1050:10:0:0:15:600:300c:326h\n"
+ "1050:10:0:0:15:600:300c:326i\n"
+ "not an ip address\n"
+ "not an ipv4 Address\n"
+ "Not an IPv5 Address";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}