import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S*)(\\{(\\S*)\\})$";
final String string = "{asvjhkhe980vz9ehh}\n"
+ "{asvjhkhe9_80vz9-ehh}\n"
+ "#anchor\n"
+ "https://linktourl.com\n"
+ "/relativepath/subdirectory\n"
+ "http://localhost:3000/page/Standard%20Page%20Components%20Test%2011%20Carousel#\n"
+ "http://localhost:3000/page/Standard%20Page%20Components%20Test%2011%20Carousel#hash\n"
+ "{0001876v9h39h9-1}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}