# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<scheme>[a-zA-Z][a-zA-Z0-9-+.]*)://(?:(?<username>(?:[\w-]|%\d\d)+)(?::(?<passwd>(?:[\w-]|%\d\d)*))?@)?(?<host>(?:[a-zA-Z][a-zA-Z0-9-]*\.?)+|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})(?<port>:\d+)?(?<path>(?:/(?:[\w-.:]|%\d\d)+)+/?|/)?(?<query>\?(?:(?:[\w-]|%\d\d)+(?:=[\w]+)?(?:&|$))*)?(?<fragment>#.*)?$"
test_str = ("https://en.wikipedia.org/wiki/Uniform_Resource_Identifier#Syntax\n"
"(↑ assuming URL, not URI; the only difference is that the host is mandatory)\n\n"
"https://regex101.com/\n"
"https://e./\n"
"https://org.\n"
"https://elearning.tgm.ac.at/pluginfile.php/297744/mod_resource/content/0/SEW5_UML_Einfuehrung.pdf\n"
"https://elearning.tgm.ac.at/mod/page/view.php?id%40_-ae=212356\n"
"https://elearning.tgm.ac.at/mod/assign/view.php?id=212239\n"
"https://elearning.tgm.ac.at/course/view.php?id=5454§ion=4\n"
"nonstandardscheme://is.still.valid\n"
"http://he.e/?\n"
"https://hy.a?a\n"
"http://h.?a&b&c=a\n"
"https://e.o.a.\n"
"http://0riedler:0%20tab-a_sco@riedler.a.wien/\n"
"http://emptypasswd:@riedler.wien/\n"
"http://a.e:33/\n"
"https://de.wikipedia.org/wiki/Wikipedia:Hauptseite\n"
"https://de.wikipedia.org/wiki/Preiselbeersauce#Zubereitung\n"
"https://toptoptoptoptoptoptoptoptoptoptoptoptoptoptoptoptoptoptoptop.top/\n"
"https://9.9.9.9/ipv4\n"
"https://2620:fe::fe/ipv6\n"
"ipv6 addresses are their own source of evil, not implementing those for now")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.