using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((notify|score)(Customer|PaymentArrangement|Product|Rejection|IntPayment|PassReset|TravelMoney)\.(access.log))$";
string input = @"notifyProduct.access.log";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}