package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((notify|score)(Customer|PaymentArrangement|Product|Rejection|IntPayment|PassReset|TravelMoney)\.(access.log))$`)
var str = `notifyProduct.access.log`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}