Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(^((\d{4}-(((0[13578]|[1][02])-(0[1-9]|[1-2]\d|3[01]))))|((\d{4}-(((0[469]|[1][1])-(0[1-9]|[1-2]\d|[3][0])))))|((\d{4}-(0[2]-(0[1-9]|[1-2]\d)))))T(([01]\d|2[0-3]):([0-5]\d):([0-5]\d))?([+-][0-2]\d:[0-5]\d)$)
/
gm
Input 1
1
New
2022-02-29T22:58:00+05:30