# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([A-Za-z ]*,)([0-9-]*,)([A-Za-z ]*)"
test_str = ("Sabrina Green,802-867-5309,System Administrator\n"
"Eli Jones,684-3481127,IT specialist\n"
"Melody Daniels,846-687-7436,Programmer\n"
"Charlie Rivera,698-746-3357,Web Developer")
subst = "\"\\1+1-\\2\\3\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.