re = /^([a-z]|[A-Z]).*\1$/m
str = 'xyyyxyx
yxyxyxy
zxyxyxz
xyxyxyy
xgjyhdtfx
yjsaudgty
xuhgrey
yudgfsx
yaaay'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end