$re = '/^.*(LIGNE|Espace|Maintien|point|Delta|ENTREE).*\n/m';
$str = 'LIGNE Calque: "506"
Espace: Espace objet
Maintien = 371b3
de point, X=103620.0722 Y=49245.7502 Z= 0.0000
vers point, X=103620.0705 Y=49187.0630 Z= 0.0000
Longueur = 58.6872, Angle dans le plan XY = 270
Delta X = -0.0016, Delta Y = -58.6872, Delta Z = 0.0000
LIGNE Calque: "506"
Espace: Espace objet
Maintien = 371ad
de point, X=103810.0724 Y=49255.0701 Z= 0.0000
vers point, X=103810.0705 Y=49187.0630 Z= 0.0000
Longueur = 68.0071, Angle dans le plan XY = 270
Delta X = -0.0019, Delta Y = -68.0071, Delta Z = 0.0000
LIGNE Calque: "506"
Espace: Espace objet
Maintien = 371af
de point, X=104000.0727 Y=49264.3900 Z= 0.0000
Appuyez sur ENTREE pour continuer:
vers point, X=104000.0705 Y=49187.0630 Z= 0.0000
Longueur = 77.3270, Angle dans le plan XY = 270
Delta X = -0.0022, Delta Y = -77.3270, Delta Z = 0.0000
LIGNE Calque: "506"
Espace: Espace objet
Maintien = 371a3
de point, X=104190.0722 Y=49246.6876 Z= 0.0000
vers point, X=104190.0705 Y=49187.0630 Z= 0.0000
Longueur = 59.6246, Angle dans le plan XY = 270
Delta X = -0.0017, Delta Y = -59.6246, Delta Z = 0.0000
LIGNE Calque: "506"
Espace: Espace objet
Maintien = 3718e
de point, X=104360.0725 Y=49256.5929 Z= 0.0000
vers point, X=104360.0705 Y=49187.0630 Z= 0.0000
Longueur = 69.5299, Angle dans le plan XY = 270
Delta X = -0.0019, Delta Y = -69.5299, Delta Z = 0.0000
LIGNE Calque: "506"
Espace: Espace objet
Appuyez sur ENTREE pour continuer:
Maintien = 37190
de point, X=104530.0727 Y=49264.3067 Z= 0.0000
vers point, X=104530.0705 Y=49187.0630 Z= 0.0000
Longueur = 77.2437, Angle dans le plan XY = 270
Delta X = -0.0022, Delta Y = -77.2437, Delta Z = 0.0000
LIGNE Calque: "506"
Espace: Espace objet
Maintien = 37192
de point, X=104700.0730 Y=49274.0157 Z= 0.0000
vers point, X=104700.0705 Y=49187.0630 Z= 0.0000
Longueur = 86.9527, Angle dans le plan XY = 270
Delta X = -0.0024, Delta Y = -86.9527, Delta Z = 0.0000
LIGNE Calque: "506"
Espace: Espace objet
Maintien = 37194
de point, X=104920.0731 Y=49278.0638 Z= 0.0000
vers point, X=104920.0705 Y=49187.0630 Z= 0.0000
Longueur = 91.0008, Angle dans le plan XY = 270
Delta X = -0.0025, Delta Y = -91.0008, Delta Z = 0.0000
Appuyez sur ENTREE pour continuer:
LIGNE Calque: "506"
Espace: Espace objet
Maintien = 37196
de point, X=105140.0731 Y=49278.0638 Z= 0.0000
vers point, X=105140.0705 Y=49187.0630 Z= 0.0000
Longueur = 91.0008, Angle dans le plan XY = 270
Delta X = -0.0025, Delta Y = -91.0008, Delta Z = 0.0000
LIGNE Calque: "506"
Espace: Espace objet
Maintien = 37185
de point, X=105428.0731 Y=49278.0638 Z= 0.0000
vers point, X=105428.0705 Y=49187.0630 Z= 0.0000
Longueur = 91.0008, Angle dans le plan XY = 270
Delta X = -0.0025, Delta Y = -91.0008, Delta Z = 0.0000
LIGNE Calque: "506"
Espace: Espace objet
Maintien = 37187
de point, X=105728.0731 Y=49278.0638 Z= 0.0000
vers point, X=105728.0705 Y=49187.0630 Z= 0.0000
Longueur = 91.0008, Angle dans le plan XY = 270
Appuyez sur ENTREE pour continuer:
Delta X = -0.0025, Delta Y = -91.0008, Delta Z = 0.0000
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;