#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)((?:[\t ]*(?:R|RE|F|FW|FWD):[\t ]*)*)(.*)"
Local $sString = "RE: RE:Fw: RE:FW: FWD: re: This is a message from a long thread re: asdf " & @CRLF & _
" Refund issued: Combination Padlock Lock Gym, School Locker, Sheds, Toolboxes Various Colours" & @CRLF & _
"Re: abc123 sent a message about Galvanised U Nails Netting Fencing Staples Chicken Wire Mesh Fences #123123123123" & @CRLF & _
"Request #0123456789: Buyer received a refund" & @CRLF & _
"Re: johndoe has sent a question about item #456456456456, ending on 03-Mar-19 05:48:20 GMT - Combination Padlock Lock Gym, School Locker, Sheds, Toolboxes Various Colours"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")