import Foundation
let pattern = #"(?<=dnsmasq-dhcp\[6292\]\:)(.*)(?=\()"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Jun 27 07:01:03 192.168.68.1 Jun 27 03:01:03 dmpromjwillekecom,50c9676c6d24,udm-1.9.3.3438 dnsmasq-dhcp[6292]: DHCPOFFER(br0) 192.168.68.53 f4:f5:d8:a6:9e:54"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)