package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<distanceMeter>\d+(?:[,.]\d+)?)(?: ?\/ ?(?<distanceFemaleMeter>\d+(?:[,.]\d+)?))? ?-m ?(?<text>\w+(?: \w+)*)`)
var str = `2000/ 1,500-m row and
2000-m row
But it fails to match
10/ 5-m row
9-m row`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}