import Foundation
let pattern = #"^\+?[1]?[2-9]{1}11$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
211
311
411
511
611
711
811
911
+211
+311
+411
+511
+611
+711
+811
+911
+1211
+1311
+1411
+1511
+1611
+1711
+1811
+1911
2114123
+2114123
+12114123
911911
411411
311511
+911911
+4119
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)