#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+\([\s\S]+?}\);"
Local $sString = "test({" & @CRLF & _
" test: 1," & @CRLF & _
" time: '11:30am'," & @CRLF & _
" color: 'red'," & @CRLF & _
" text: '123455};3456'" & @CRLF & _
"});" & @CRLF & _
"" & @CRLF & _
"test({" & @CRLF & _
" test: 1," & @CRLF & _
" time: '11:30am'," & @CRLF & _
" color: 'red'," & @CRLF & _
" text: '123455;3456'" & @CRLF & _
"});"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")