re = /(?<=TODAY)(?!\S*?([YMD])(?:(?!\1).\S)*\1)(?:[-+]\d{1,3}[YMD]){1,3}(?=\s|$)/m
str = 'TODAY-1M+12M'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end