$re = '/^(.*)\s+(\S+)\s+\((.*)\)$/m';
$str = 'Foo Bar-8.io 5.61.0-rc-1 (data)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);